В темах WordPress появляется проверка версий PHP

В темах WordPress появляется проверка версий PHP

Проверка версий PHP наконец-то проходит в систему тем WordPress. Эта функция была включена в основной WordPress три дня назад. Такое нововведение предотвратит установку или активацию конечными пользователями темы, несовместимой с их текущей версией PHP или WordPress. Это изменение должно произойти в версии WordPress 5.5.

Эта функция уже давно присутствует в списках пожеланий многих авторов тем, особенно при проверке версий PHP. Авторы плагинов получили возможность поддерживать определенные версии PHP, начиная с WordPress 5.2. А авторам тем осталось чувствовать себя людьми второго сорта когда речь заходит о добавлении основных функций и терпеливо ожидают момента когда авторы плагинов получат новые блестящие инструменты, которые они с нетерпением ждали.

Ранее код для ручной обработки проверки версий в отдельных темах был более сложным, чем в плагинах. Авторам темы необходимо было выполнить проверку совместимости после переключения темы и блокировки предварительного просмотра темы в настройщике с помощью двух различных методов, в зависимости от версии WordPress пользователя. Это при условии, что авторы темы освещали все свои основания.

Пользователи не имели реального способа узнать, будет ли тема работать на их сайте, прежде чем устанавливать и пытаться активировать ее.

Эта ситуация также сдерживала некоторых авторов тем от перехода на более новые версии PHP. В течение многих лет многие поддерживали PHP 5.2. Постепенно некоторые из этих же авторов переходят к новым функциям вплоть до PHP 5.6, который теперь является минимумом, поддерживаемым WordPress. Однако не многие сделали скачок к PHP 7 и новее.

До сих пор не было никакого механизма, позволяющего пользователю узнать, что ему нужно обновить свой PHP, чтобы использовать определенную тему.

Некоторые авторы тем могут продолжать поддерживать более старые версии PHP, такие как 5.6, для потенциально более широкой пользовательской базы. Однако разработчики, которые хотят переключиться на более новые функции, теперь могут сделать это с поддержкой основной платформы.

Leave a Reply